Terrier/Requirements

Previous Terrier/LiveDoc/DFRDescription, Terrier/CategoryLiveDoc, Next Terrier/LiveDoc/SampleApps

Requirements for using Terrier

Terrier comes with all you need, except the Java Virtual Machine. We suggest you use Java 1.4, although Terrier works just as well with Java 1.5.

You can download Java from the [WWW] Sun Microsystems Java website.

If you intend to develop with Terrier, you'll want the SDK (Software Development Kit), otherwise the J2SE Java Runtime Environment (JRE) will suffice. Current versions at time of writing:

Java2 1.4

J2SE v 1.4.2_06 SDK

J2SE v 1.4.2_06 JRE

Java2 1.5

JDK 5.0 Update 1

JRE 5.0 Update 1

Note that SDK has become JDK in Java 2 1.5, which stands for J2SE Development Kit.

Tested Operating Systems

Terrier has been tested on:


Previous Terrier/LiveDoc/DFRDescription, Terrier/CategoryLiveDoc, Next Terrier/LiveDoc/SampleApps

last edited 2010-02-23 18:58:13 by CraigMacdonald